Utility ACT

I am trying to test drives. Once upon a time I did it. But something has clearly changed in the ACT utility. The results are very strange. Server: dell r440, perc h330, each disk is RAID0, disk SAMSUNG PM883, 894.3 GiB. RAID configuration:

Read Policy No Read Ahead
Write Policy Write Through
Stripe Size 64K

Result:

ACT-STORAGE CONFIGURATION
device-names: / dev / sdd
num-devices: 1
service-threads: 200
test-duration-sec: 3600
report-interval-sec: 1
microsecond-histograms: no
read-reqs-per-sec: 4000
write-reqs-per-sec: 2000
record-bytes: 1536
record-bytes-range-max: 0
large-block-op-kbytes: 128
replication-factor: 1
update-pct: 0
defrag-lwm-pct: 50
compress-pct: 100
disable-odsync: no
commit-to-device: no
commit-min-bytes: 0
tomb-raider: no
tomb-raider-sleep-usec: 0
max-lag-sec: 10
scheduler-mode: noop

DERIVED CONFIGURATION
record-stored-bytes: 1536 ... 1536
internal-read-reqs-per-sec: 4000
internal-write-reqs-per-sec: 0
large-block-reads-per-sec: 47.06
large-block-writes-per-sec: 47.06

HISTOGRAM NAMES
reads
/ dev / sdd-reads
large-block-reads
large-block-writes

        reads
        %> (ms)
slice 1 2 4 8 16 32 64
----- ------ ------ ------ ------ ------ ------ ------
    1 93.75 76.92 28.98 0.02 0.00 0.00 0.00
----- ------ ------ ------ ------ ------ ------ ------
  avg 93.75 76.92 28.98 0.02 0.00 0.00 0.00
  max 93.75 76.92 28.98 0.02 0.00 0.00 0.00

Yes, an hour is not enough. But actually I have tested this before and the results are no better. And this test is for clarity. I also tested on a Dell HBA330 controller. The results are similar. I still have tests with a Perc H730 controller two years ago (values ​​are approximate)

1% - 1.34
2% - 0.64

When testing without a controller on a dell r340 server, for example, there are no problems. As a result, this r440 server works very well in production. But how to use the ACT utility correctly in order to immediately see the correct result?

© 2021 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.