Asinfo cannot connect loopback

asinfo -v "set_config:context=TestNameSpace;id=blocked;set=TestSet;set-delete=true"
request to  127.0.0.1 : 3000  returned error

but ifconfig can list loopback ip.

lo        Link encap:Local Loopback  

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:179078 errors:0 dropped:0 overruns:0 frame:0

          TX packets:179078 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0 

          RX bytes:16137706 (16.1 MB)  TX bytes:16137706 (16.1 MB)

And aerospike.conf network part as follows:

network {

        service {
                address any
                port 3000

                # Uncomment the following to set the `access-address` parameter to the
                # IP address of the Docker host. This will the allow the server to correctly
                # publish the address which applications and other nodes in the cluster to
                # use when addressing this node.
                # access-address <IPADDR>
        }

        heartbeat {

                # mesh is used for environments that do not support multicast
                mode multicast
                  address 239.20.99.222
                port 3009

                # use asinfo -v 'tip:host=<ADDR>;port=3002' to inform cluster of
                # other mesh nodes
                # mesh-port 3002

                interval 150
                timeout 10
        }

        fabric {
                port 3001
        }

        info {
                port 3003
        }

I cannot figure out where the problem is .

Thanks!

Have you tried specifying the ip address of the node?

Hello kporter,

No, I did not specifying the ip address because I installed server on local host .

I try other command like asinfo -v 'status', it works.

and I try specifying ip address.It also returns the simliar error as:

request to  'myIp': 3000  returned error

Thanks.

Steve

Looks like you are using set_config instead of set-config, try:

Edit: corrected the context

asiStrong Textnfo -v "set-config:context=namespace;id=blocked;set=TestSet;set-delete=true"

If this is incorrectly documented somewhere, a link would be very appreciated. Thanks.

Hi kporter,

Thanks I, was my oversight.

So I tried asinfo -v "set-config:context=TestNameSpace;id=blocked;set=TestSet;set-delete=true",

But it only returns one word “error”.

I queried the set. The data is unchanged.

Best Regards,

Steve

Didn’t realize TestNameSpace was the context. The context should be “namespace”, the id should be the namespace name. If this still fails, please supply the full aerospike.conf.

Hi kporter -_-

Thanks.Now it succeed.But after I remove the set,I tried to insert data with my client.If failed.

it returns error: " opt/aerospike/sys/udf/lua/ldt/ldt_common.lua:1844: 1428:LDT-TOP Record Create Error "

I tired several times.I find it manages to insert records after 2 minutes or so.

I am not sure whether it is a normal result.It seems to me the remove command takes about 2 minutes to finish.Or anything wrong with my configuration.

Correct, by default it is at least 2-4 min. It operates on nsup intervals.

A post was split to a new topic: The set-delete command is returning an error

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.