Enterprise Bad install


#1

Postby chrise99 » Wed Jan 02, 2013 5:12 pm

Maybe cuz I have a bridge br0 with eth0 enslaved to it? This is on Centos 6.3 (not a VM) This is enterprise trial

Jan 03 2013 00:08:09 GMT: INFO (config): (base/cfg.c:2087) namespace test { Jan 03 2013 00:08:09 GMT: INFO (config): (base/cfg.c:2087) replication-factor 2 Jan 03 2013 00:08:09 GMT: INFO (config): (base/cfg.c:2087) storage-engine memory Jan 03 2013 00:08:09 GMT: INFO (config): (base/cfg.c:2087) } Jan 03 2013 00:08:09 GMT: WARNING (cf:misc): (id.c:163) can’t get physical address, tried eth, bond, wlan. fatal: 19 No such device Jan 03 2013 00:08:09 GMT: CRITICAL GLOBAL (config): (base/cfg.c:672) could not get unique id and/or ip address critical error: backtrace: frame 0 /usr/bin/cld() [0x46ad7f] critical error: backtrace: frame 1 /usr/bin/cld() [0x407022] critical error: backtrace: frame 2 /usr/bin/cld() [0x403e0f] critical error: backtrace: frame 3 /lib64/libc.so.6(__libc_start_main+0xfd) [0x383fa1ecdd] critical error: backtrace: frame 4 /usr/bin/cld() [0x403929]


#2

Post by chrise99 » Thu Jan 03, 2013 9:58 am OK fixed it -sorry - should’ve RTFMd.!

Post by young » Thu Jan 03, 2013 4:57 pm

I want to make sure others can see the resolution, because I know I personally don’t always read the manual.

If I understand things correctly, you ran into an issue where the database was not able to automatically detect the network interface. The system will automatically detect certain device types (like “eth0”), but you can manually set it using the “network-interface-name” parameter in the file “/etc/citrusleaf/citrusleaf.conf” in the network section. The example below references “br0”:

network {
        service {
               ... 
               address 10.0.2.131
               port 3000
               reuse-address
               network-interface-name br0
               ...
        }
}

Post by chrise99 » Thu Jan 03, 2013 5:12 pm

Exactly

I added the line network-interface-name br0 and all was well :slight_smile:

root@big:/etc/citrusleaf>sudo /etc/init.d/citrusleaf start Starting citrusleaf: [ OK ] Starting citrusleaf daemon: [ OK ] root@big:/etc/citrusleaf>