Unknown Namespace Error with AQL

Hello Devs,

So I just started with Aerospike and I am facing this unknown namespace error quite frequently.

Specs:

  • Ubuntu 18.04
  • Aerospike 4.7.0.2 - Community edition

Steps:

  1. I configured aerospike.conf with new namespace, suppose myApp
  2. I restarted aerospike service, using systemctl start aerospike
  3. Once started, I started aql shell and entered, SELECT * FROM myApp and it shows, Error: (1) unknown-namespace.
  4. Then I inserted data through Node.js client successfully, and when I do SELECT * FROM myApp again, I get the following, which to my surprise, shouldn’t happen because I am getting data now.

What could be the cause? Because once I restart my system, and aerospike service is restarted, it shows only this, -> Error: (1) unknown-namespace

Any help is appreciated. Thank you.

Okay, I just found this, me and my colleague have different local setup of Aerospike.

When I run show namespaces, it shows namespaces from other machine (as we are connected on same WIFI). Can anyone explain me this?

namespace name is case sensitive. you created

myapp

but are looking for

myApp

in AQL.

1 Like

can you run

$ asadm -e info

and share the output?

1 Like

Sorry for not making it clear… actually, myApp was just a made-up name in first pic as it was my project name as the namespace.

In second picture, I tried reinstalling and now creating a new namespace with name myapp.

Thank you.

Your nodes are forming a cluster with one another. You can prevent this by configuring cluster-name which will then only allow your node to join other nodes with the same cluster-name.

Another option is to configure the node to use ‘mesh’ heartbeats instead of ‘multicast’.

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.